jonathan gamez
Status
Back
Maintenance
backend update
Completed 11 Apr at 09:00pm CEST.
Affected services
cywa.ch
emby.cywa.ch
Completed
Maintenance completed
Posted 11 Apr at 09:00pm CEST.
Started
server will be down for about 1 hour
Posted 11 Apr at 08:00pm CEST.